ads

LACP with STP Sim






I saw this lab in a couple of places on the internet..They were incomplete, or worst..Over worked with extra configuration that I didn't need..and only helps to get me more confused and inaccurate results.So I will do this on my own , and I will check the final result.

Scenario:



You work for SWITCH.com. They have just added a new switch (Switch A) to the existing network as shown in the topology diagram.
RouterA is currently configured correctly and is providing the routing function for devices on SwitchA and SwitchB. Switch B is currently configured correctly, but will need to be modified to support the addition of Switch A. SwitchA has a minimal configuration. You have been tasked with competing the needed configuring of SwitchA and SwitchB. SwitchA and SwitchB use Cisco as the enable password.

 First of all , we found that we have a lot of information and we can not address them in the same order where we posted it. Second, you will need some preparation before you start working this labs.Third ,we will number the order when we address certain specific issue so you will know what we are doing..Fourth, certain part of this lab can not be done in packet Tracer , like "Switchport trunk encapsulation" command , so we strongly suggest that you practice them with real equipment




                                       Configuration Requirements for Switch B

The VTP and STP configuration modes on SwitchB should not be modified.
· SwitchB needs to be the root switch for vlans 11, 12, 13, 21, 22 and 23. All other vlans should be left are their default values.


Configuration Requirements for Switch A

– Vlan 21, Name: Marketing, will support two servers attached to fa0/9 and fa0/10
– Vlan 22, Name: Sales, will support two servers attached to fa0/13 and fa0/14
– Vlan 23, Name: Engineering, will support two servers attached to fa0/15 and fa0/16
– Access ports that connect to server should transition immediately to forwarding state upon detecting the connection of a device.
– SwitchB VTP mode needs to be the same as SwitchB.
– SwitchA must operate in the same spanning tree mode as SwitchB.
– No routing is to be configured on SwitchA.
– Only the SVI vlan 1 is to be configured and it is to use address 192.168.1.11/24.


Inter-switch Connectivity Configuration Requirements:
 
– For operational and security reasons trunking should be unconditional and Vlans 1, 21, 22 and 23 should tagged when traversing the trunk link.
– The two trunks between SwitchA and SwitchB need to be configured in a mode that allows for the maximum use of their bandwidth for all vlans. This mode should be done with a non-proprietary protocol, with SwitchB controlling activation.
– Propagation of unnecessary broadcasts should be limited using manual pruning on this trunk link.




So, in other words, your main task is going to be:

1. Use non proprietary mode of aggregation with Switch B being the initiator

2. Use non proprietary trunking and no negotiation

3. Restrict only to vlans needed

4. SVI on vlan 1 with ip 10.10.10.2 255.255.255.0

5. Configure switch A so that nodes other side of Router C are accessible

6. Make switch B the root


Step 1.-Notes before starting working with the lab: 


A.-Design a topology like this in Packet Tracer

Please check the switches and the servers


B.-You will need some handy configuration before you start the configuration, step by step




C.-Use this useful commands BEFORE  AND AFTER configure the lab to know exactly what is the switch situation

 

D.-after running these commands you will find a configuration similar to this:




 STEP 2: Development of the lab


A)show run or show vlan to see if we need to create Vlan  21- 23



Section 1 : Creation of the VLAN

 This is what we have :




SW-A(config)# vtp mode transparent

SW-A(config)# spanning-tree mode rapid-pvst 
Note: Access ports that assigned to VLANs 
should transition immediately to forwarding state upon detecting the 
connection of a device. 
 
 
 SW-A(config)# vlan 21
SW-A(config-vlan)# name Marketing
SW-A(config-vlan)# exit

SW-A(config)# vlan 22
SW-A(config-vlan)# name Sales
SW-A(config-vlan)# exit

SW-A(config)# vlan 23
SW-A(config-vlan)# name Engineering
SW-A(config-vlan)# exit

SW-A(config)# vlan 99
SW-A(config-vlan)# name TrunkNative
SW-A(config-vlan)# exit 
 


Note: If the trunk gets packets that are not label to any VLAN ,they will go to VLAN99 by default

SW-A(config)#int range fa0/3 – 4
SW-A(config-int-range)#no switchport access vlan 98
SW-A(config-int-range)#switchport trunk encapsulation dot1q
SW-A(config-int-range)#switchport mode trunk
SW-A(config-int-range)#switchport trunk native vlan 99
SW-A(config-int-range)#switchport trunk allowed vlan 1,21-23
SW-A(config-int-range)#channel-protocol lacp
SW-A(config-int-range)#channel-group 1 mode active
SW-A(config-int-range)#exit
 
 
Note:Use"no switchport access vlan 98"command to form a trunk link 

Note :Lacp is the  not propietary trunking protocol
 
 
 SW-A(config)# int port-channel 1
SW-A(config-if)# switchport trunk encapsulation dot1q
SW-A(config-if)# switchport mode trunk
SW-A(config-if)# switchport trunk native vlan 99
SW-A(config-if)# switchport trunk allowed vlan 1,21-23
SW-A(config-if)# no shutdown
SW-A(config-if)# end

SW-A(config)# int range fa 0/9 – 10
SW-A(config-int-range)# switchport mode access
SW-A(config-int-range)# switchport access vlan 21
SW-A(config-int-range)# spanning-tree portfast
SW-A(config-int-range)# no shutdown
SW-A(config)# exit

SW-A(config)# int range fa 0/13 – 14
SW-A(config-int-range)# switchport mode access
SW-A(config-int-range)# switchport access vlan 22
SW-A(config-int-range)# spanning-tree portfast
SW-A(config-int-range)# no shutdown
SW-A(config-int-range)# exit

SW-A(config)# int range fa 0/15 – 16
SW-A(config-int-range)# switchport mode access
SW-A(config-int-range)# switchport access vlan 23
SW-A(config-int-range)# spanning-tree portfast
SW-A(config-int-range)# no shutdown
SW-A(config-int-range)# exit

SW-A(config)# interface vlan 1
SW-A(config-if)# ip address 192.168.1.11 255.255.255.0
SW-A(config-if)# no shutdown
SW-A(config-if)# exit

SW-A(config)# ip default-gateway 192.168.1.1
SW-A(config)# end 

SW-A# copy run start





SW-B(config)# vlan 21
SW-B(config-vlan)# name Marketing
SW-B(config-vlan)# exit

SW-B(config)# vlan 22
SW-B(config-vlan)# name Sales
SW-B(config-vlan)# exit

SW-B(config)# vlan 23
SW-B(config-vlan)# name Engineering
SW-B(config-vlan)# exit

SW-B(config)# spanning-tree vlan 11-13,21-23 root primary

SW-B(config)# int range fa0/3 – 4
SW-B(config-int-range)# no switchport access vlan 98
SW-B(config-int-range)# switchport trunk encapsulation dot1q
SW-B(config-int-range)# switchport mode trunk
SW-B(config-int-range)# switchport trunk native vlan 99
SW-B(config-int-range)# switchport trunk allowed vlan 1,21-23
SW-B(config-int-range)# channel-protocol lacp
SW-B(config-int-range)# channel-group 1 mode active
SW-B(config-int-range)# exit

SW-B(config-if)# int port-channel 1
SW-B(config-if)# switchport trunk encapsulation dot1q
SW-B(config-if)# switchport mode trunk
SW-B(config-if)# switchport trunk native vlan 99
SW-B(config-if)# switchport trunk allowed vlan 1,21-23
SW-B(config-if)# no shutdown
SW-B(config-if)# end

SW-B# copy running-config startup-config
 
 
 

Step 3:

 
 
 

 show vlan 

show spanning-tree summary

 
 

                   #show run

 
 
 



 show ip int brief

 

                                                   show etherchannel port-channel

 

                                                            show vtp status

 
 
 
 
 
 

This lab is done and confirmed..If you like it,please share..

Thank you !
 
LACP with STP Sim LACP with STP Sim Reviewed by ohhhvictor on 6:35:00 AM Rating: 5

No comments:

 photo imagen120.jpg
Theme images by 5ugarless. Powered by Blogger.